Pagina precedente | 1 | Pagina successiva
Facebook  

cerca vert

Ultimo Aggiornamento: 20/05/2017 08.14
Autore
Stampa | Notifica email    
Post: 1
Registrato il: 19/05/2017
Città: PADOVA
Età: 53
Utente Junior
excel 2010
OFFLINE
19/05/2017 11.05

buongiorno, ho bisogno di aiuto con il cerca vert

in sostanza il problema è questo:

ho 3 costruttori che con un proprio codice producono lo stesso prodotto

vorrei fare un cross reference

in base alla descrizione trovare quale articolo usano i costruttori
e fino a qui ho risolto

ma se invece ho l'articolo (di uno qualsiasi dei produttori) come faccio a cercare qual'è quello degli altri
ho provato con cerca vert o cerca orizz ma non risolvo

grazie
Cerca carattere in gruppo di cellecerca17/09/2017 11.13 by pilupilu
Concorso Pronostici Serie A 2017/2018Ipercaforum134 pt.20/09/2017 00.01 by possum jenkins
Marzia RoncacciTELEGIORNALISTE FANS FORU...76 pt.20/09/2017 07.03 by Collantandtacchilover
Post: 3.210
Registrato il: 21/06/2013
Città: NAPOLI
Età: 64
Utente Master
Excel 2013
OFFLINE
19/05/2017 11.10

Ciao Luca

Allega un file di esempio con dati fittizi, spiegazione e risultato desiderato inserito a mano

Alfredo
Post: 93
Registrato il: 15/01/2016
Città: ROMA
Età: 44
Utente Junior
2010
ONLINE
19/05/2017 11.11

Buongiorno allega un file con um po di dati e il risultato da ottenere scritto a mano
Post: 1
Registrato il: 19/05/2017
Città: PADOVA
Età: 53
Utente Junior
excel 2010
OFFLINE
19/05/2017 11.16

Post: 3.211
Registrato il: 21/06/2013
Città: NAPOLI
Età: 64
Utente Master
Excel 2013
OFFLINE
19/05/2017 12.42

Io dal file non ho capito nulla.

Puoi cercare di spiegare meglio?

Alfredo
Post: 2
Registrato il: 19/05/2017
Città: PADOVA
Età: 53
Utente Junior
excel 2010
OFFLINE
19/05/2017 14.27

cerca vert
se la ditta B produce il prodotto 190021 e sapendo che (vedi foglio 2) è esattamente il codice 3420P21 della ditta A e 53015050 della ditta C (ma questo lo so io) come faccio dal foglio 1 digitando il prodotto 190021 (quindi ricerca articolo) trovare gli equivalenti delle altre ditte ??
in fondo è un normale cross reference tra diversi produttori
una ditta produce una cosa che gli altri chiamano con un codice diverso, ma è lo stesso oggetto
Post: 530
Registrato il: 02/08/2015
Utente Senior
Excel 2013
OFFLINE
19/05/2017 21.14

Ciao a tutti,

@luca
in base al tuo file allegato, nella cella D11 del "Foglio1" (da copiare poi a destra) puoi usare questa formula matriciale (quindi da confermare con la combinazione di tasti CTRL+MAIUSC+INVIO anzichè solo con INVIO):
=INDICE(Foglio2!$B$1:$D$12;MAX(INDICE(SE.ERRORE(RIF.RIGA($B$4:$D$12)/(Foglio2!$B$4:$D$12=$B$11);"");;));RIF.COLONNA(A1))

ti riallego il file...

Ciao
Tore
Post: 94
Registrato il: 15/01/2016
Città: ROMA
Età: 44
Utente Junior
2010
ONLINE
19/05/2017 21.32

Buonasera oltre alla soluzione di Cromagno (un saluto) propongo due soluzioni in D11
=SE.ERRORE(CERCA.VERT(INDICE(Foglio2!$A$4:$A$12;PICCOLO(SE(Foglio2!$B$4:$D$12=Foglio1!$B$11;RIF.RIGA($A$4:$A$12)-3);1));Foglio2!$A$4:$D$12;RIF.COLONNA(B$1);0);"")

oppure

=SE.ERRORE(INDICE(Foglio2!$A$4:$D$12;CONFRONTA(INDICE(Foglio2!$A$4:$A$12;PICCOLO(SE(Foglio2!$B$4:$D$12=Foglio1!$B$11;RIF.RIGA($A$4:$A$12)-3);1));Foglio2!$A$4:$A$12;0);RIF.COLONNA(B$1));"")

entrambe da attivare con i tasti CTRL+SHIFT+INVIO e trascinare fino a F11
Post: 1.199
Registrato il: 10/10/2013
Città: VICENZA
Età: 62
Utente Veteran
excel 2016
OFFLINE
20/05/2017 08.14

ciao
tutto perfetto ma solo per didattica
cominciamo a vedere le cose dalla parte di chi ha solo le basi e non
è esperto.

qual è il punto in comune dei codici?

l'articolo.

bene con una formula elementare trovo l'articolo
di riferimento


=SE.ERRORE(INDICE(Foglio2!A4:A12;CONFRONTA(B11;Foglio2!B4:B12;0));SE.ERRORE(INDICE(Foglio2!A4:A12;CONFRONTA(B11;Foglio2!C4:C122;0));INDICE(Foglio2!A4:A12;CONFRONTA(B11;Foglio2!D4:D12;0))))


11
una sequenza di indice confronta abbinati ad un se.errore

in D11 scrivo
la stessa formula che trovo in D6 sostituendo b11con la formuletta sopra e mi esce

=CERCA.VERT(SE.ERRORE(INDICE(Foglio2!$A$4:$A$12;CONFRONTA($B$11;Foglio2!$B$4:$B$12;0));SE.ERRORE(INDICE(Foglio2!$A$4:$A$12;CONFRONTA($B$11;Foglio2!$C$4:$C$12;0));INDICE(Foglio2!$A$4:$A$12;CONFRONTA($B$11;Foglio2!$D$4:$D$12;0))));Foglio2!$A$4:$D$12;RIF.COLONNA(B1);FALSO)



lunga ma sempliciotta

il rif.colonna lo uso al posto di 2-3-4 per potermi spostare di cella verso destra senza riscrivere l'indice.

sempliciotta ma fattibile sempre che non ci siano una moltitudine di codice per lo stesso articolo.

formuletta per principianti allo sbaraglio [SM=x423026]


[Modificato da federico460 20/05/2017 08.17]
Amministra Discussione: | Chiudi | Sposta | Cancella | Modifica | Notifica email Pagina precedente | 1 | Pagina successiva
Nuova Discussione
 | 
Rispondi
Cerca nel forum
Tag discussione
Discussioni Simili   [vedi tutte]
Home Forum | Bacheca | Album | Utenti | Cerca | Login | Registrati | Amministra
Tutti gli orari sono GMT+01:00. Adesso sono le 09.14. Versione: Stampabile | Mobile | Regolamento e Privacy
FreeForumZone [v.4.4.2] - Copyright © 2000-2017 FFZ srl - www.freeforumzone.com