Pagina precedente | 1 | Pagina successiva
Facebook  

Sommare costi fissi e non

Ultimo Aggiornamento: 21/03/2017 10.26
Autore
Stampa | Notifica email    
Post: 21
Registrato il: 01/09/2016
Città: BOMPORTO
Età: 46
Utente Junior
2007
OFFLINE
20/03/2017 11.02

Nel creare un foglio di lavoro per calcolare dei preventivi ai clienti mi sono imbattuto in questa formula da trovare:

sommare i costi delle varie fasi moltiplicando i soli costi non fissi per le qtà del prodotto.
In allegato un file di esempio

(ho provato con somma.se + confronta, ma non ci sono riuscito)

Grazie
Come prendersi gioco di una città intera e non pagarne le conseguenzeForza Trevisonon16/03/2017 20.08 by dart1972
lettura del pensiero, siamo davvero sicuri che Satana non ci riesca?Testimoni di Geova Online...non14/03/2017 07.02 by I-gua
La battaglia delle Termopili (e non solo!) spiegata con La Roma (da sempre "laboratorio" e "incubatore" di rivoluzionarie rivelazioni)Senza Padroni Quindi Roma...non17/03/2017 15.52 by Giacomo(fu Giacomo)
Post: 1.103
Registrato il: 10/10/2013
Città: VICENZA
Età: 62
Utente Veteran
excel 2016
OFFLINE
20/03/2017 11.32

ciao

ho utilizzato una riga d'appoggio che
puoi nascondere o mettere con il carattere bianco
e utilizzato


=MATR.SOMMA.PRODOTTO(--(B6:J6<>"x");B5:J5)*O2



scusa mi sono dimenticato una parte


=MATR.SOMMA.PRODOTTO(--(B6:J6<>"x");B5:J5)*O2+MATR.SOMMA.PRODOTTO(--(B6:J6="x");B5:J5)



la tua formula in spiegazione è sbagliata
prova a vedere moltiplichi anche i fissi
[Modificato da federico460 20/03/2017 11.39]
Post: 1.104
Registrato il: 10/10/2013
Città: VICENZA
Età: 62
Utente Veteran
excel 2016
OFFLINE
20/03/2017 11.40

Post: 21
Registrato il: 01/09/2016
Città: BOMPORTO
Età: 46
Utente Junior
2007
OFFLINE
20/03/2017 11.59

Ciao Federico,
grazie davvero per la risposta ed effettivamente la formula funziona.
Una domanda: non si riesce ad evitare quella riga aggiuntiva?
Te lo chiedo in quanto userò questo foglio con più righe (una sotto l'altra) per fare più preventivi

Grazie ancora
[Modificato da Eso71 20/03/2017 11.59]
Post: 1.106
Registrato il: 10/10/2013
Città: VICENZA
Età: 62
Utente Veteran
excel 2016
OFFLINE
20/03/2017 12.10

si puoi evitarla cambiando la tabella
dove metti le x

ti vario il file
Post: 22
Registrato il: 01/09/2016
Città: BOMPORTO
Età: 46
Utente Junior
2007
OFFLINE
20/03/2017 19.00

Ciao Federico,
non ho ben capito, devi aggiungere un file con la variazione che hai detto?
Post: 1.107
Registrato il: 10/10/2013
Città: VICENZA
Età: 62
Utente Veteran
excel 2016
OFFLINE
21/03/2017 00.26

ciao
scusa sono andato al lavoro [SM=x423052]

non ci riesco a variare la situazione l'unica cosa è nascondere il tutto
guarda ora

https://www.dropbox.com/s/a6ssz6ly1wjplds/costi%20fissi.xlsx?dl=0



così non ti infastidisce
Post: 510
Registrato il: 02/08/2015
Utente Senior
Excel 2013
OFFLINE
21/03/2017 01.51

Ciao a tutti,

per non usare la riga di appoggio, si potrebbe utilizzare la formula matriciale (quindi da confermare con la combinazione di tasti CTRL+MAIUSC+INVIO anzichè solo con INVIO) da mettere nella cella L5:

=SOMMA(SE(VAL.NUMERO(CONFRONTA(CONFRONTA($B$3:$J$3;$P$6:$P$13;0);INDICE(($O$6:$O$13<>"x")*(RIF.RIGA($O$6:$O$13)-5);;);0));$B5:$J5*$O$2;$B5:$J5))

Riallego il file (le formule sono in colonna M)...

Ciao
Tore
[Modificato da cromagno 21/03/2017 01.55]
Post: 23
Registrato il: 01/09/2016
Città: BOMPORTO
Età: 46
Utente Junior
2007
OFFLINE
21/03/2017 08.26

Re:
federico460, 21/03/2017 00.26:

ciao
scusa sono andato al lavoro [SM=x423052]

non ci riesco a variare la situazione l'unica cosa è nascondere il tutto
guarda ora

https://www.dropbox.com/s/a6ssz6ly1wjplds/costi%20fissi.xlsx?dl=0



così non ti infastidisce



Non ti preoccupare, ora mi studio la formula di cromagno che pare andar bene e non fa uso della riga aggiuntiva.
Ti ringrazio davvero molto per l'aiuto.


Post: 24
Registrato il: 01/09/2016
Città: BOMPORTO
Età: 46
Utente Junior
2007
OFFLINE
21/03/2017 08.28

Re:
cromagno, 21/03/2017 01.51:

Ciao a tutti,

per non usare la riga di appoggio, si potrebbe utilizzare la formula matriciale (quindi da confermare con la combinazione di tasti CTRL+MAIUSC+INVIO anzichè solo con INVIO) da mettere nella cella L5:

=SOMMA(SE(VAL.NUMERO(CONFRONTA(CONFRONTA($B$3:$J$3;$P$6:$P$13;0);INDICE(($O$6:$O$13<>"x")*(RIF.RIGA($O$6:$O$13)-5);;);0));$B5:$J5*$O$2;$B5:$J5))

Riallego il file (le formule sono in colonna M)...

Ciao
Tore



Ottimo! Pare funzionare. Ora me la studio un secondo e se ho domande ripasso :) Grazie davvero!


Post: 1.109
Registrato il: 10/10/2013
Città: VICENZA
Età: 62
Utente Veteran
excel 2016
OFFLINE
21/03/2017 10.26

Ciao Cro

ancora oggi mi perdo sui RIF.RIGA [SM=g27818]

[SM=x423047]
Amministra Discussione: | Chiudi | Sposta | Cancella | Modifica | Notifica email Pagina precedente | 1 | Pagina successiva
Nuova Discussione
 | 
Rispondi
Cerca nel forum
Tag discussione
Discussioni Simili   [vedi tutte]
Home Forum | Bacheca | Album | Utenti | Cerca | Login | Registrati | Amministra
Tutti gli orari sono GMT+01:00. Adesso sono le 16.38. Versione: Stampabile | Mobile | Regolamento e Privacy
FreeForumZone [v.4.4.2] - Copyright © 2000-2017 FFZ srl - www.freeforumzone.com